Can we fill up our benchmarks?


#1

@bmarkons @tgxworld can we fill up all our current benchmarks? as it stands the rails releases benchmarks are blank


#2

Sure :+1: I’ll be able to do it next week, I took small break this week :blush:


#3

I’ve gone ahead and kicked off the backfill :slight_smile:


#4

hmm looks like the benchmarks are somewhat broken

/ruby-bench-suite/rails/vendor/bundle/ruby/2.4.0/gems/activerecord-5.0.0.beta2/lib/active_record/connection_adapters/abstract/database_statements.rb:36:in `select_all': undefined method `preparable' for #<Arel::Visitors::MySQL:0x007f81fb4cc258> (NoMethodError)

#5

@tgxworld maybe check if latest rails releases docker image is pushed to docker hub. I am not sure if I did that, I was working on rails trunk mostly.


#6

@bmarkons Could you have a look at the Ruby benchmarks too? They stopped working on July 11 2017. Thanks in advanced!


#7

Sure, I’ll do my best :slight_smile:


#8

What are you currently working on ATM? Don’t spend too much time looking into the broken benchmark and let me know if it is too difficult. Thank you for the good work so far!


#9

I am working on pg suite setup in order to debug this :

I’ve tried to fix Rails suite which has been broken.

Error saying :

Could not find gem 'arel (= 9.0.0.alpha)', which is required by gem 'activerecord (= 5.2.0.alpha)', in any of the sources.

I still haven’t looked into Ruby benchmarks.


#10

Had to push in another fix.

https://github.com/ruby-bench/ruby-bench-suite/commit/a1c0a0b14ab6edf6477df663e6c4db4e7f0fdc48

Backfilling the benchmarks now.


#11

Oops spoke too soon. It was backfilling fine for a while but then something blew up.


#12

What’s wrong?

It looks like everything is going fine with rails releases…

Except these deprecation warnings for ::Fixnum and ::Bignum – but that’s because of ruby 2.4.0 version.


#13

Oh I see… Running rails versions 4.0.x failed with :

Bundler could not find compatible versions for gem "tzinfo":
  In Gemfile:
    rails (= 4.0.13) was resolved to 4.0.13, which depends on
      activesupport (= 4.0.13) was resolved to 4.0.13, which depends on
        tzinfo (~> 0.3.37)

    tzinfo-data was resolved to 1.2013.3, which depends on
      tzinfo (>= 1.0.0)